1. Home
  2. Probleemoplossing
  3. Help mijn PHP-versie is te laag

Help mijn PHP-versie is te laag

Wij, als Affiliate Held, hebben een eis gesteld aan de minimale PHP-versie voor jouw WordPress site. Is je PHP-versie lager dan 7.0 dan kan het zomaar zo zijn dat Affiliate Held niet compatible is met jouw site. Kortom: wij hebben de Affiliate Held plugin niet getest met PHP-versies onder de 7. In dit document leggen we uit waarom we deze keuze hebben gemaakt en hoe je je PHP-versie kunt verhogen/updaten.

Wat is PHP?

PHP is de programmeertaal waarop WordPress is gebouwd. De manier van het “spreken” van deze programmeertaal wordt met de jaren steeds efficiënter en wordt daarom met enige regelmaat geüpdatet met als doel een beter functionerende en veiligere website te maken. Om je website veilig, snel en modern te houden is het dus belangrijk om er voor te zorgen dat je in ieder geval een PHP-versie van 7 of meer hebt.

Voordelen up-to-date versie PHP

  • Verbeterde snelheid: met iedere update wordt de PHP efficiënter ingericht. Kleine bugs worden opgelost, code wordt herschreven/verbeterd waardoor je volgens WordPress een prestatieverhoging van minimaal 3 tot 4x in je website snelheid mag verwachten.
  • Veiligere website: digitale criminaliteit neemt steeds meer toe. Met het updaten van je PHP-versie zorg jij dat je gebruik maakt van de nieuwste beveiligingsfuncties. Oude PHP-versies hebben dit niet.
  • Betere posities in Google: dit is een secundair voordeel, maar met een snellere website is het mogelijk om beter beloond te worden door verschillende zoekmachines.
  • Betere “user experience”: door toenemende snelheid is het voor bezoekers prettiger om door je site te navigeren. Je website zal bezoekers langer en beter vasthouden (ja dit is een Google ranking factor).
  • Beschermd tegen schade: een veiligere website beschermt je tegen mogelijke kosten en reputatieschade die gepaard gaan met een gehackte website.

Waarom een PHP-versie van 7 of hoger?

Snelheid, veiligheid en resultaat zijn kernwoorden van Affiliate Held. Wij willen ervoor zorgen dat ons klant, maar ook de klant van onze klant (jouw website bezoekers) de meest optimale ervaring hebben. Heb je een PHP-versie van 7 of lager dan kunnen wij dit simpelweg niet garanderen.

Hoe update je je PHP-versie?

Voordat je begint met het updaten van je PHP-versie is het belangrijk om te weten dat dit een redelijk technisch proces is. Heb je nog nooit je PHP-versie verhoogd? Vraag dan om hulp aan vrienden, je programmeur of je hosting partij. Ons advies: bespaar niet op goede hulp en ga zeker niet spelen met de PHP instellingen als je hier géén verstand van hebt!

Stap 1: Back-up

Toch zelf aan de slag met het verhogen van je PHP-versie? Zorg dan dat je een goede back-up maakt van je site. Als je een fout maakt heb je tenminste nog al je website bestanden correct opgeslagen.

Er zijn veel gratis WordPress plugins beschikbaar waarmee je eenvoudig een back-up kan maken: https://wordpress.org/plugins/search/backup/. Een andere optie is om via je hosting provider een back-up te (laten) maken.

Stap 2: Updates

Zorg ervoor dat je WordPress versie, je thema’s en al je geïnstalleerde plugins geüpdatet zijn. Dit is natuurlijk een proces wat je regelmatig moet onderhouden, maar het is aan te raden om zeker te weten dat je site correct werkt voordat je je PHP-versie gaat verhogen.

Stap 3: Check of je PHP-versie verhoogd kan worden

Download de plugin: PHP Compatibility Checker (WP Engine). Met deze plugin kan je onderzoeken of jouw website in dit moment in staat is (compatible is) om de PHP-versie te verhogen. Deze plugin geeft je eventueel aan of en welke aanpassingen je zou moeten doen voordat je je PHP-versie verhoogt. Let op: software/websites kunnen technische problemen bevatten die deze plugin niet kan herkennen. Het uitvoeren van deze stap is een stukje risico beperking voordat je je PHP-versie gaat verhogen. Erg belangrijk dus om bij stap 1 een goede back-up te maken.

Stap 4: Los problemen op

Loop je door het resultaat van de PHP Compatibility Checker tegen problemen aan? Zorg dan dat je deze oplost voordat je verder gaat met het verhogen van je PHP-versie (stap 6).

Stap 5: (herhaal) Back-up

Het is nooit een overbodige luxe om nogmaals een back-up te maken. Software en websites zijn nou eenmaal ingewikkeld en het maken van een tweede back-up kan veel tijd en zorgen besparen in de toekomst. Heb je stap 1 tot en met 4 doorlopen zonder problemen dan is het verstandig om nogmaals een back-up te maken.

Stap 6: Update je PHP-versie

Het is nu tijd om je PHP-versie te verhogen. In de meeste gevallen zul je de PHP-versie moeten updaten via je hosting provider. De beste keuze is om de klantenservice van je eigen hosting provider te benaderen en te vragen of ze dit voor je kunnen doen. Scheelt veel tijd en weet je zeker dat het goed wordt gedaan.

Doe je liever zelf de update? Dan adviseren we nog steeds om contact te zoeken met je hosting provider. Het updaten van je PHP-versie is bij iedere provider verschillend en zullen dit ook op een andere manier hebben gedocumenteerd.

Vragen?

Heb je na het lezen van dit document vragen gekregen, kom je er niet uit of wil je gewoon contact met ons? Vul dan ons contactformulier of stel een vraag in onze community,

Was dit artikel behulpzaam?

Gerelateerde artikelen

Plaats een reactie